CD-i Emulator could not be registered

CD-i Emulator is the first fully evolving windows compatible emulator project of the Philips CD-i system. Discuss the emulator, compatibility issues, seek help and support to get the program operating and post what you'd like to see in future revisions of the program. CD-i players ROM (BIOS) requests, begging and links will not be tolerated. Otherwise feel free to post your thoughts on this amazing new piece of software.
Post Reply
goldenegg
Burn:Cycle Activated
Posts: 3
Joined: Thu Mar 17, 2011 7:12 pm

CD-i Emulator could not be registered

Post by goldenegg » Mon Jan 28, 2013 7:46 pm

I'm a registered user of CDIEmu, but can no longer use it.

Last year I performed a fresh install of Windows 7. After trying to register the emulator, I got the error "CD-i Emulator could not be registered". This error now appears every time I start the emulator.

I have e-mailed the developer several months ago, but never heard back. Has anyone else ran in to this issue? I'd really like to start using it again.

User avatar
cdifan
CD-i Emulator Author
Posts: 906
Joined: Fri Jun 24, 2005 6:19 am
Location: The Netherlands
Contact:

Post by cdifan » Tue Jan 29, 2013 9:36 pm

I must have missed your mail, sorry. The issue you describe is caused by Windows Vista/7/8 UAC and can be ignored. It merely means that file extensions could not be registered, CD-i Emulator should otherwise function normally.

goldenegg
Burn:Cycle Activated
Posts: 3
Joined: Thu Mar 17, 2011 7:12 pm

Post by goldenegg » Tue Jan 29, 2013 9:51 pm

Thanks for responding.

I'll need to double-check, but I'm pretty sure starting the emulator gives me an error that my evaluation has expired. Could something have messed up since I was previously using 0.53b2?

I'll download 0.52 again and try with a fresh copy.

Post Reply