DVC nightmare

If you encounter any problems with your CD-i system or have difficulty operating some software for CD-i then post your problems here. With help from the CD-i community and the vast resources hosted on the CDinteractive network we should be able to solve any trouble your experiencing.
Post Reply
CDIWHY
Burn:Cycle Activated
Posts: 4
Joined: Thu Feb 01, 2007 1:11 am

DVC nightmare

Post by CDIWHY » Sat Mar 17, 2007 6:13 pm

OK..I own TWO DVC's. Both have the identifiying # 22ER9141.
They fit a 220 exactly. The center port connector pushes in snug. BUT, my new 910 unit has the same DVC inside dimesions and the DVC slides in eactly, BUT...the pin lineup either doesn't fit right, or the 4 raised diodes or transisters prevent the DVC from allowing the pin connector from pushing in snug. The dvc remainsin, but loose and not pushed in. :(
Anyone have a source for a 910 dvc? There seems to be a radical difference in fit/configuration in the business end of the port/connector inside a 910 unit! Am I missing an adaptor, or does the 910 unit take a toatlly different shaped connector end dvc????????

User avatar
cdifan
CD-i Emulator Author
Posts: 912
Joined: Fri Jun 24, 2005 6:19 am
Location: The Netherlands
Contact:

Post by cdifan » Sat Mar 17, 2007 7:39 pm

I know that some early professional 60x series players required physically replacing a connector board to connect the DVC cartridge, but I was under the impression that no consumer player needed this.

Could it be that you have a very early 910 player? Care to post a picture of the DVC connector?

CDIWHY
Burn:Cycle Activated
Posts: 4
Joined: Thu Feb 01, 2007 1:11 am

Problem fixed!

Post by CDIWHY » Sat Mar 17, 2007 10:07 pm

Somehow....I pushed just right and the dvc pushed in and I'm up and running! I can now play many titles & films. I have ordered several titles from an ebay seller. I'm sooooooooooooooooooooo happy! :)

Post Reply