Memorex CD-i 2200 does not power up

If you encounter any problems with your CD-i system or have difficulty operating some software for CD-i then post your problems here. With help from the CD-i community and the vast resources hosted on the CDinteractive network we should be able to solve any trouble your experiencing.
Post Reply
sdatexas
Burn:Cycle Activated
Posts: 5
Joined: Mon Oct 08, 2007 4:38 pm

Memorex CD-i 2200 does not power up

Post by sdatexas » Mon Oct 08, 2007 4:43 pm

Hello, I have a Memorex CD-i 2200 (sold in USA by Radio Shack) that I purchased new. It sat around for a bit and now does not power up at all. Is there a fuse inside that can be replaced or any other possibility that I should examine before I give up on it? Any advise would be appreciated. I have some games that we would still play if it worked.

Thanks,

Steve
Love that Whacky Golf!

User avatar
Bas
CDinteractive Admin
Posts: 3039
Joined: Mon Jun 20, 2005 11:14 am
Location: the Netherlands
Contact:

Post by Bas » Fri Oct 12, 2007 6:54 am

The memorex player is just a licensed 450 model, right? So maybe the power brick has lost life? If one wire lost connection, the system appears to be dead. I guess, when it would be about the frightening 'timekeeper battery', the system would at least show a sign of life! So perhaps your problem is not that big, check all the connections and fiddle around with the brick to see if at one point it starts to power up. If it does, solder the lost wire back on!

Let us know how you get on!

sdatexas
Burn:Cycle Activated
Posts: 5
Joined: Mon Oct 08, 2007 4:38 pm

No power brick

Post by sdatexas » Fri Oct 12, 2007 3:34 pm

Hello,
Thanks for the reply. This unit does not have a power brick. It has a normal power cord. The unit is more similar to the Phillips CD-i 220. Normal component size. Has slot for video cart in rear, etc. If there is a battery or fuse or something that could shut it down completely, please let me know how to access it. I would love to use the unit when our kids come home for Thanksgiving and Christmas. Miss Whacky Golf! HA!
Thanks.
Steve
Love that Whacky Golf!

User avatar
Bas
CDinteractive Admin
Posts: 3039
Joined: Mon Jun 20, 2005 11:14 am
Location: the Netherlands
Contact:

Post by Bas » Fri Oct 12, 2007 4:04 pm

So.... When you powert he player, nothing happens? No indication on the display? Does the system try to start, open the tray? Does it make any sounds? In that case, it sounds like the power supply is either burnt or a wire is loose. Have you tried to open the player (screws on each side) and have a look inside? Any suspicious things? We love some pictures ;)

sdatexas
Burn:Cycle Activated
Posts: 5
Joined: Mon Oct 08, 2007 4:38 pm

Will check it out

Post by sdatexas » Fri Oct 12, 2007 4:28 pm

I'll open it up and see what there is to see. Don't know what I'm looking for, but I can take some photos. May be a day before I can get to it. Thanks again.
Steve
Love that Whacky Golf!

sdatexas
Burn:Cycle Activated
Posts: 5
Joined: Mon Oct 08, 2007 4:38 pm

Photos of interior

Post by sdatexas » Wed Oct 17, 2007 9:42 pm

Hello. I took the lid off and took some photos of the interior of my unit. How do I post them on this site?

Still no power. Checked the continuity of the power cable. Checked ok. Don't know what to look for next. Nothing seems obviously scorched or burned up. Any ideas?
[/img]
Love that Whacky Golf!

sdatexas
Burn:Cycle Activated
Posts: 5
Joined: Mon Oct 08, 2007 4:38 pm

Photos

Post by sdatexas » Fri Oct 26, 2007 3:25 pm

I posted my photos of the internals of the Memorex unit on Flickr. Go to this address to see them.

http://www.flickr.com/photos/sdatexas/s ... 719587829/

If that doesn't work, you can go to this address and choose the CD-i set.

http://www.flickr.com/photos/sdatexas/

Anyone with ideas of how to troubleshoot my CD-i? No power up at all. See previous posts.

Thanks,

Steve
Love that Whacky Golf!

Post Reply