Page 1 of 1

CD-i 910 Power Problem

Posted: Thu Jan 03, 2008 8:52 pm
by Feefle
Hi, I recently bought a CD-i 910 and when I tried connecting it to the power, the console would start making a buzzing noise and after about half a minute, smoke started to appear. I turned it off and each time I turn it back on it buzzes so I know it's not COMPLETELY fried. The power we use here is 120v (Canada/U.S.) and at the back of the console it says:

0.41 amps
410 mA

Can anyone help me out? Do I need an adapter so this American unit works in... America?!

EDIT: When I turn it on, I can see a white screen on the TV, and more smoke coming from the power vent of the CD-i. And when the CD-i is turned on, there is no image at the front (No ERROR or anything)

EDIT: I opened the system and found out that a belt was loose, I attached it and now there is no buzzing I think, but each time I turn the system on, the laser just quickly jerks and does it again when I turn the power off. It doesn't make sense, how can there be too much power?

Posted: Fri Jan 04, 2008 7:53 pm
by Bas
I'm glad you find out more by yourself, because i don't know what you mean all the time. What do you mean when the laser 'jerks'? Is it dirty? Is it able to switch over the trail?

Posted: Fri Jan 04, 2008 8:20 pm
by Feefle
Yeah it moves over the rail, when the system is turned off the laser is at the bottom and when I power it up the laser quickly moves to the top of the rail and nothing happens, then when I switch it off the laser goes crazy for a millisecond and goes back down the rail.

EDIT: And the laser is clean, the whole CD-i looks very brand new and the insides look fine.

I noticed this on the power source chip:


Maybe it might mean something, I don't know. It looks like it works at 220v but that clashes with the 120v printed on the back of the system, I'm no good at electronics :roll:

Again I tried turning the system on but this time I kept the cd tray open, each time I turned it on the drive would slightly push itself back in, c'mon this thing has made all my newly-bought cd-i games useless :( And there's most likely a simple solution I just haven't found out yet...