Page 1 of 1

A common CD-i Remote problem - Fix inside!(Battery contacts)

Posted: Mon Jul 05, 2010 1:20 pm
by Adr990
Hey all,

I don't think people around here wouldn't come up with the idea, but still.

The connection with the Batteries on the CD-i Remote might not connect so well anymore, and so it looks like it doesn't work anymore.

You can't confirm this until you tried this a few times, till you're sure the tin foil is placed correctly.
At least, I'm using tin foil to fix it easily. :)

Over at: I found the follow tutorial: ... 00-h/8.png ... 00-h/9.png

Selfish French people, ugh

I've typed all the single chars into Google Translate. And it told me that a common problem could be the contacts with the Batteries are the problem. Which I already was thinking about looking at it myself though.

So, here is a easy solution, you should try it when your CD-I Remote doesn't work anymore. :)

Open the Battery cover:

Than get some foil and make it like this size:

Now make sure you have new batteries, or recharged so you can confirm it with a more translatable mind.

Pull the double battery deeper inside like this, so a little space will be there.
(Better contacts at the battery in the back, and now also in the front. That's the idea.)

Now test it. And if it doesn't work try to put the foil otherwise or grab a another piece of tin foil.
Besides, the tin foil should be a little fat. So it will close up the space you just made as the picture above shows. Not just sitting there lose.
Also make sure its not to width or has to much height.

Do it right, carefully watch if it touches the contacts or not ,as it should of course.

(The tin foil in this picture isn't placed to well, but you should get the basic idea.)

Not working yet? Try again, may clean the contacts also. And of course, recharge/try new batteries for confirmation. ;)

Good luck, hopefully it worked. And so saved a great CD-i set up. :D


Posted: Thu May 19, 2011 9:47 pm
by opt_fr_
Good evening,

I've a similar issue with my cd-i remote, but it isn't the same model as yours (the picture can be found here : ... ction,206/ (1st image to the right)).

Thanks for this tutorial, but does it exists a tutorial for my cdi-mote model ? Or maybe the internal structure of the remote is the same and this tutorial is enough ?

When I move the cursor to the left or right, there are 3 possibilities :
- the cursor moves to the right direction (1 chance on 2)
- the cursor moves to the opposite direction (1 chance on 4)
- the cursor doesn't move, you have to insist (1 chance on 4)

This is very frustrating when playing CS, Labyrinth of Crete and Hotel Mario (sometimes you fall of the stage because of that, yupie ! But HM is playable with a cdimote).

Thanks in advance

Posted: Mon Jul 11, 2011 3:54 pm
by opt_fr_
I'll try to open it with a torx 6 screwdriver when I find one (tried t8 but too large)

model : cd-i thumbstick (remote)

Posted: Sat Jul 16, 2011 1:33 pm
by Adr990

It's not the same problem I had, and which I posted a solution for.
My problem was not having good contact with the battery in my Remote.

But as for your remote, I think a good old joystick cleaning will do wonders.
Might check the contacts of everything too once it's opened up anyways.

Good luck.