CD-i 210 stopped working!!!!

If you encounter any problems with your CD-i system or have difficulty operating some software for CD-i then post your problems here. With help from the CD-i community and the vast resources hosted on the CDinteractive network we should be able to solve any trouble your experiencing.
Post Reply
johnnycoelho
Burn:Cycle Activated
Posts: 3
Joined: Mon Mar 19, 2012 1:19 am

CD-i 210 stopped working!!!!

Post by johnnycoelho » Thu Oct 18, 2012 5:10 pm

Hi everyone.
I have this cdi model for long years ago. My remote stopped working, so i bought a new repair kit and it was working good.
However, some days ago, my cdi stopped working. It turns on, shows "CD-I" on cdi screen but nothing appears on television now :/ i didn't change any settings or so, It just stopped working. How can i fix it?!
PLZ HELP :/

johnnycoelho
Burn:Cycle Activated
Posts: 3
Joined: Mon Mar 19, 2012 1:19 am

Post by johnnycoelho » Fri Oct 19, 2012 2:53 pm

plz help :/

User avatar
Adr990
Burn:Cycle Activated
Posts: 19
Joined: Mon Jul 05, 2010 10:42 am
Location: The Netherlands

Post by Adr990 » Tue Oct 23, 2012 6:01 pm

Heya,

Are you sure the cables are connected right?

Or did you get any sort of error before you didn't even get video output from your CDi?
Like memory or date messages?

Also, what model do you have?


The CD-i turns on, but do you hear the disc spinning? What happens if you press Play on the CD-i/Remote?

If the CD-i starts to make more reading noises once you hit the play button the CD-i still works fine.
Than there is something wrong with the video output for sure.

Good luck!

Adr990
I repaired the CD-i 210, 470, 450, and 220 from noisy and hanging disc tray's and the famous Timekeeper problem!

I own a 470 and 450, along with 87 CD-i titles and a CD-i promo pin.

Post Reply